概要
VVAULT製品において、動作遅延や動作不良等が見られる場合にウイルススキャンソフトが影響している場合がある
詳細
VVAULT製品を運用開始した際に動作遅延や動作不良等が見られる場合、ご利用中のウイルススキャンソフトが影響している場合があります。特定のフォルダ、プロセスを除外設定した場合に状態が緩和される事がありますので、対応可否をご検討ください。
ウイルススキャンソフトの設定方法につきましてはご利用中のウイルス対策ソフトメーカーへお問い合わせください。
また、除外設定をする場合にはセキュリティリスクが伴いますので十分にご注意ください。
製品インストール上、除外設定が必須となる項目もございますのであわせてご確認ください。
原因
ウイルススキャンソフトとVVAULTとの相性による問題です。
対応方法
ウイルススキャンソフトにて、下記フォルダおよびプロセスの除外設定を行ってください。
なお下記のパスはデフォルト値となります。各環境にあわせて読み替えてください。
またフォルダの除外設定はインスタンス2やBACKUP環境がある場合にも同様に設定してください。
【VVAULT】
◆ フォルダ
インストールフォルダ
・C:\Program Files\VVAULT
DBデータ保存先
・インストール時に設定したフォルダ
構成ストレージ指定フォルダ
・管理対象パスにて設定したフォルダ
(構成ストレージがネットワークドライブの場合、ネットワークドライブのサーバまたはNAS上で除外設定が必要なケースがあります※1)
◆ プロセス
C:\Program Files\VVAULT\
VirtualDrive.exe
VVAULT.exe
VVAULTBackup.exe
C:\Program Files\VVAULT\pgsql\bin\
pg_ctl.exe
postgres.exe
※Trend Micro Apex One™をご利用の場合、上記プロセスすべてを挙動監視設定>除外設定>承認済みプログラムリストに追加してください。
※1:構成ストレージがネットワークドライブの場合の除外設定について
構成ストレージがネットワークドライブの場合、ネットワークドライブとして指定している共有フォルダがあるサーバまたはNAS上でウイルススキャンソフトを使用されているのであれば、そのウイルススキャンソフトでネットワークドライブに指定されている共有フォルダ(のパス)を除外してください。
例えば、ネットワークドライブの管理対象パスとして「\\filesvr\share1」が指定されていた場合、「filesvr」サーバー上でこの共有フォルダのパスが「F:\share1」だったとすると、「filesvr」サーバーのウイルススキャンソフトの除外設定に「F:\share1」を追加してください。